Help: Problem with ice textures

Share your ZH-related videos, player streams, gifs, and more!
Locked
User avatar
ProfessorX
Posts: 196
Joined: Wed Sep 10, 2014 4:07 pm
Battle.net Name: ProfessorX
Battle.net Char Code: 1530
Battle.net Server: NA

Help: Problem with ice textures

Post by ProfessorX » Sat May 09, 2015 9:17 pm

http://i.imgur.com/M797jfe.jpg

I'm having this problem where the texture of the ice will change as I move the camera up and down (north south).

There is a clear cut line that separates the terrain quality and I was wondering if anyone knew how to fix this. I thought this had to do with depth of field, but the Post-Processing setting doesn't help. Normally I play with everything on low where this doesn't happen (all the ice will look smooth). It seems if you raise the Shaders setting (medium and above) it will happen. Even everything on Ultra doesn't solve it; I've tested a gazillion settings combos, but I can't seem to fix this.

Any thoughts?

I've checked youtube, and it happens in all the casts as well (for the casters that use medium+)
User avatar
LittleDicky
Posts: 602
Joined: Thu Nov 27, 2014 7:22 pm
Battle.net Name: LittleDicky
Battle.net Char Code: 0
Battle.net Server: EU

Re: Help: Problem with ice textures

Post by LittleDicky » Mon May 11, 2015 11:10 am

Try this:

1. Set your settings in game as you want them.
2. Turn off SC
3. Open the file: /Documents/StarcraftII/Variables.txt
4. Modify (or add) these lines:

Code: Select all

TerrainTextureHiResCacheSize=180
TerrainTextureLowResCacheSize=0
TerrainTextureSize=XXX <- try to keep it at default value or modify. It can increase the quality.
5. Check it out.

Related thread: http://www.zealothockey.net/viewtopic.php?f=9&t=1175

Changing certain graphic options in game can reset your custom settings. In my experience, changing settings not related with textures does not remove my custom settings for textures.
Image
Image
Image
User avatar
LittleDicky
Posts: 602
Joined: Thu Nov 27, 2014 7:22 pm
Battle.net Name: LittleDicky
Battle.net Char Code: 0
Battle.net Server: EU

Re: Help: Problem with ice textures

Post by LittleDicky » Wed May 13, 2015 3:33 pm

Hi, i have just upgraded my PC today, so i could try fixing this myself:

Comparison album:
http://imgur.com/a/5khd2#0

This is how my original Variables.txt looked like for Ultra Settings:

Code: Select all

TerrainTextureHiResCacheSize=8
TerrainTextureLowResCacheSize=50
TerrainTextureSize=768
This is how to change it to eliminate low res parts:

Code: Select all

TerrainTextureHiResCacheSize=56
TerrainTextureLowResCacheSize=50
TerrainTextureSize=768
Image
Image
Image
User avatar
ProfessorX
Posts: 196
Joined: Wed Sep 10, 2014 4:07 pm
Battle.net Name: ProfessorX
Battle.net Char Code: 1530
Battle.net Server: NA

Re: Help: Problem with ice textures

Post by ProfessorX » Wed May 13, 2015 5:52 pm

That's awesome dude thank you! <3 <3
Locked